Galère sur les mise à jour automatique dans WordPress (extensions et core)

Depuis quelques jours je m’étais rendu compte qu’il m’était impossible de faire des mises à jour automatiques. Lorsque je le faisais j’obtenais un message du type

Impossible de créer le dossier /home/chemindemoninstallwordpress/wp-content/upgrade/nomduplugin.tmp

Après avoir parcouru pas mal de pages et essayé des chmod dans tous les sens, la suppression du dossier upgrade, nettoyage du fichier .htacces, etc. je me suis rendu compte que c’était le plugin AskApache Password Protect qui me bloquait les mises à jour.

Je l’ai donc désactivé pour le moment, je me pencherai de nouveau sur ce problème dans quelques jours… si j’ai le temps 😀

4 réflexions au sujet de « Galère sur les mise à jour automatique dans WordPress (extensions et core) »

  1. Génial, je galérais depuis un moment sans comprendre d’où pouvait venir ce blocage des mises à jour sur mon blog Auto Entrepreneur Info.
    Un grand merci d’avoir posté l’explication, je commençais à désespérer de trouver une solution à part réinstaller tout wordpress !

    As-tu trouvé pourquoi ce plugin bloquait les mises à jours ?

  2. Bonjour Ronan,

    De rien pour le truc.
    Je n’ai pas eu le temps de plus me pencher sur le problème, le plugin est donc pour le moment toujours désactivé 😀

    Sylvain

  3. Effectivement, c’est bon de voir la réponse à son problème,
    Merci,

    Dur de se mettre à jour sur bons plugins de sécurité…

  4. Pour info, après avoir rencontré le même problème, il faut désactiver AskApache Password, puis mettre à jour l’extension AskApache Password (actuellement version 4.6.8). On peut ensuite la réactiver, et il n’y a plus de problème de mises à jour auto. 🙂

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*